VOIP mit Fritzbox 7490 hinter UDM-Pro

  • Ich habe einen Kollegen der mir bisher behilflich war. Er selber hat ein USG und arbeitet hauptberuflich in der IT. Bei ihm klappt voip problemlos.

    Wir habe so einiges probiert... Wir haben es einfach nicht hinbekommen.


    Aktuell steht die fritzbox außerhalb meines netzwerkes (und sie steht im Keller neben dem Glasfaser Modem). Sie stellt die Internet Verbindung her und die UDM-PRO hängt dahinter. Ansonsten ist sie nur die Telefonanlage.


    Ich möchte die fritzbox wieder in die mittlere Etage verlegen. Wir haben zu starke Probleme mit dem Empfang der DECT Telefonen. Dazu muß sie hinter die UDM-PRO.


    So viel zur Ausgangslage.

    Ich habe sogar noch eine weitere Fritzbox 7490, die wir hinter der UDM-PRO zum testen hingestellt haben. Wir haben Ports in der Firewall angelegt (obwohl ich oft höre, dies wäre nicht nötig).


    Fritzbox: 192.168.178.1 mit dhcp

    per Lan1 an das Glasfasermodem angeschlossen.


    UDM-Pro hat 192.168.1.1 (wan steht auf dhcp und bekommt die ip von der fritzbox)


    Sobald die Fritzbox hinter der UDM-PRO hängt, kann sie keine voip verbindung zu gegenstelle aufbauen.

    Wir sind mit dem Latein am Ende.

    Fast alles, was ich im Netz gefunden habe, handelt von Fritzboxen VOR der UDM.

  • was ich nicht richtig verstehe, welche gerät baut bei dir die Internet Verbindung über das Modem auf, die udmpro oder die FRITZ!Box.? Du schreibst du hättest 2 Fritz boxen.
    Falls du hinter dem Modem eine FRITZ!Box hast und dahinter die udmpro, dann hast du doppeltes NAT und musst in der ersten FRITZ!Box allen Datenverkehr an die udmpro per Exposed Host weiterleiten.

  • Was ich mal gelesen habe und was wichtig sein soll ist, dass die FritzBox den Port offenhält in der UDMP.

    Bei mir läuft auch meine FritzBox soweit hinter der UDMP als Telefonanlage für mein DECT Telefon.

    Habe hierbei meine FritzBox natürlich im IP-Client Modus mit einer statischen IP.

    Danach habe ich mein DECT Telefon eingerichtet unter dem Reiter Telefonie und danach meine Rufnummer mit dem Assistenten eingerichtet.


    Musste kurz warten danach hat meine FritzBox die Rufnummer registrieren können.


    Gruß Marco.

    VDSL 100 Profil 17A -> Vigor 165 (4.2.3.STD) -> UDM-Pro (1.9.2) -> USW-24-PoE (5.43.23) -> 2xnanoHD (5.43.23)

  • uboot21 aktuell baut die fritzbox vor der UDM-pro die internet verbindung auf. ich habe es auch als exposed host versucht. brachte keine änderung.


    Mxrco2001 das ist korrekt. in der fritzbox stellt man ein, in welchen intervallen die fritzbox sich bei der udm meldet, um den port offen zu halten. z.b. alle 30 sekunden oder alle 5 minuten (wenn ich das noch richtig in erinnerung habe). ich wäre froh, wenn es so einfach wie bei dir gewesen wäre. so ist es bei mir auch geplant - einfacher ip client modus und mehr als telefon macht die fritzbox dann auch nicht mehr. mein kollege in österreich und ich haben schon so manche nacht im discord damit verbracht, das zum laufen zu bekommen.

    [email protected] froesch

    -

    UDM-PRO 1.9.0.3413 Controller Version 6.1.61 | USW-PRO-24 5.43.23.12533 | 2x UAP-AC-PRO

    APC Smart-UPS X1500 | Racknex UM-SBC-204 mit Raspi4 8gb | Synology 1815+ | Synology 212j | Fritzbox 7490

    Einmal editiert, zuletzt von froesch ()

  • Wenn alles korrekt eingestellt ist müsste es ja funktionieren.


    Falls du bereits in der UDM Pro mit Firewall regeln experimentiert hast, solltest du diese testweise mal komplett ausschalten um Fehler beim Setup auszuschliessen.

    Auch die Fritzbox würde ich mal kritisch überprüfen ob alles korrekt weitergeleitet wird, was auch wichtig ist: In der Fritzbox vor der UDM Pro dürfen keine Reste mehr einer anderen VOIP Telefon eingerichtet sein, auch keine alten Firewall regeln oder Port Weiterleitungen der Fritzbox.

    Wenn es irgendwie umzusetzen ist würde ich die Fritzbox mal vielleicht in auslieferzustand versetzen und neu einrichten wenn nichts mehr hilft.


    Wie bereits erwähnt ist nichts extra zu beachten, Voraussetzung ist allerdings das keine andere Einstellung den Zugang blockt

  • ich werde am wochenende nochmal die fritzbox vor der udm abnehmen, dann die udm die internetverbindung aufbauen lassen (wie es sein sollte) und die fritzbox hinter der udm anwerfen.


    ich habe beide fritzboxen einem reset unterzogen, als die udm ankam und in betrieb genommen wurde. (vor 5 wochen)

    thread management hatte ich auch mal deaktiviert. das brachte mich auch nicht weiter. außer den angelegten ports für telefon "wan out" ist sonst nichts an firewall/portweiterleitungen angelegt.


    ich mache dann mal von allem screenshots. das hilft hoffentlich bei der problemfindung.

    [email protected] froesch

    -

    UDM-PRO 1.9.0.3413 Controller Version 6.1.61 | USW-PRO-24 5.43.23.12533 | 2x UAP-AC-PRO

    APC Smart-UPS X1500 | Racknex UM-SBC-204 mit Raspi4 8gb | Synology 1815+ | Synology 212j | Fritzbox 7490

  • Das hört sich nach einem vernünftigen Plan an.

    Ein Hinweis noch zu den Firewall Regeln.

    Bei WAN Out gehört eigentlich keine Regel rein, es sei denn du blockst im nächstem Schritt deinen Internetzugang.


    Generell baut die Fritzbox hinter der UDM ja die Verbindung mit dem SIP Server auf.

    Heisst in dem Fall gilt die vorgefertigte Regel "allow established/related sessions" für den Verkehr rein. Das heisst der Verbundene SIP Server kann auch dich erreichen von ausserhalb.

    Das ist der Grund warum die Fritzbox so eingestellt werden muss den Port immer aktiv zu halten.

    Falls die Verbindung mit dem SIP Server zu stande gekommen ist, wird ein vollkommen anderer Zufalls Port für das Gespräch verwendet, damit der SIP Port frei bleibt um ggf weitere Gespräche entgegen zu nehmen.

    Eine Firewall Einstellung ist also nicht nötig wenn du nicht unnötig etwas geblockt hast, eine Port Weiterleitung auch nicht, da die Fritzbox die Verbindung aufbaut, nicht umgekehrt.

  • Eine Firewall Einstellung ist also nicht nötig wenn du nicht unnötig etwas geblockt hast, eine Port Weiterleitung auch nicht, da die Fritzbox die Verbindung aufbaut, nicht umgekehrt.

    Kann ich bestätigen. FB läuft hinter UDM als Nur-Telefonanlage seit einer Woche ohne Probleme. (vgl. Umstellung von Fritzbox 6591 als Router auf UDM Pro)

    *******************************************************************************************************************************************************************************

    UAP nanoHD, UniFi Switch PRO 24 PoE, UDM Pro, UAP Pro

    Mini Switch, Switch 8 POE 150, Kabelmodem TC4400; FB 6591, Synology NAS, Pi Hole + ISC DHCP

  • Hall Ivy,

    das Prinzip was ich geschildert habe funktioniert mit jedem Router.

    Es gibt natürlich viele Wege dass es trotzdem geblockt wird, die Klassiker sind hier sicher falsche Firewall, falsche DNS Einstellung oder andere Filter die das verhindern, ich habe keine USG, wüsste aber nicht warum es nicht so funktionieren sollte.


    So lange das der SIP Client auf seinen Wunsch Ports nach aussen Verbindung aufbauen darf und kann, ist alles in Ordnung. Es muss lediglich zusätzlich eingestellt werden den Port aktiv offen zu halten.

  • hi, bei mir ist folgende Konfiguration: Kabel-Fritzbox 6490 - UDMPro - 2.Fritzbox als Telefonanlage. Die 2. FB ist als Telefoniegerät in der ersten FB angemeldet. Das heißt, alle Anrufe werden auf die 2. FB weitergeleitet. Bei hat das auch nicht anders funktioniert. Warum die 2. FB dann überhaupt? Leider geht sonst die FritzApp Fon auf den Iphones nicht, wenn nicht beide im gleichen Netzwerk sind.


    Gruß Jörg

    UDM Pro - USW24-Pro-PoE - USW24-Pro - USW-Flex - 3x nanoHD - 2x AC-M - Bridge zum Gartenhaus über NanoBeam - US8-150 - AC-M-Pro - Bridge zum Gerätehaus über NanoStation - US8-60 - AC-M, 2x UVC-G3-Bullet

    Laboranlage: USG-Pro4 - US16-PoE - CloudKey Gen2+


    Ubiquiti-Zertifikate: UEWA, UBWA

  • ich habe mehrere settings für die telefonverbindung ausprobiert und wir haben auch mehrere nummern.

    habe eine, die vom anbieter vergeben wurde und die wir eh nicht nutzen (daher ungeschwärzt).

    threat management ist aus und auch meine firewall regeln für voip habe ich entfernt.

    die udm stellt die internetverbindung her. die fritzbox ist mit lan1 zum netzwerk verbunden.


    dennoch bekommt die fritzbox den voip timeout

  • Hallo froesch,

    ich gehe davon aus dass die SIP Einstellungen schon mal mit easybell funktioniert haben, fa ich mich mit dem Anbieter und den Einstellungen nicht auskenne, sonst kannst du dort auch noch RFC3842 einstellen.

    In den Anschlusseinstellungen ganz unten bei DSL und WAN hast du die beiden Sachen VLAN und separate Verbindung deaktiviert gehe ich von aus.

    Benutzt du VLAN in deinem Netzwerk? Die IP liegt in deinem Hauptnetzwerk und die Fritzbox leuchtet auch grün bei Internetverbindung?

    Entschuldige die vielen Fragen, aber ich versuche nur Fehler auszuschliessen.

    Welchen DNS Server hast du in deinem LAN und WAN eingetragen, sind diese korrekt oder nutzt du piHole oder sonst welche Filter? Es gibt auch Anbieter die benötigen Ihren eigenen DNS Server zur Nutzung des VOIP Servers.

  • jepp die settings haben so in der fritzbox vor der udm funktioniert. ich hatte auch bereits verschiedene settings ausprobiert, also "rufnummer für die anmeldung verwenden" oder "eigene rufnummer im internationalen rufnummernformat übermitteln".


    RFC3842 habe ich mal angemacht. brachte auch nix.


    die beiden settings bei dsl und wan sind standardmäßig deaktiviert und auch nicht angerührt worden.


    ich benutze keine vlans. die ip liegt im hauptnetzwerk, power/dsl leuchtet grün.


    keine sache, irgendwie muß man ja der sache auf die spur kommen ;-)

    als dns server ist aktuell nur der von google bei wan1 mit 8.8.8.8 angegeben. ich habe zwar nen pihole, aber zum testen habe ich alles abgeklemmt, was davor hängen könnte.


    falls dir das irgendwie weiterhilft:

    https://www.easybell.de/hilfe/…r-voip-konfiguration.html

    https://www.easybell.de/hilfe/…xperteneinstellungen.html

    [email protected] froesch

    -

    UDM-PRO 1.9.0.3413 Controller Version 6.1.61 | USW-PRO-24 5.43.23.12533 | 2x UAP-AC-PRO

    APC Smart-UPS X1500 | Racknex UM-SBC-204 mit Raspi4 8gb | Synology 1815+ | Synology 212j | Fritzbox 7490

  • Noch eine kleine Sache bei der Fritzbox, bei Netzwerk Netzwerkeinstellungen steht bei Betriebsart IP Client im Netzwerk? Per LAN

    In der Fritzbox hab ich alles identisch dann, ausser das ich zusätzlich IPv6 aktiviert habe und das ich die IP von der UDM Pro beziehe.


    In deinem LAN ist auch kein manueller DNS Server aktiviert? Das wird sichtbar wenn dort der DHCP Server aktiviert ist.

    Alles andere wir Firewall war ja bereits ausgeschaltet

  • ip client settings habe ich im inet.jpg angehangen. steht auf ip client.

    ipv6 habe ich überall deaktiviert. ich weiß nicht mehr genau warum, ich glaube ich hatte da probleme mit den nas servern irgendwie.


    ach du hast keine feste ip vergeben? also ich habe ja die fritzbox außerhalb des dhcp bereichs angesiedelt, ihr eine feste ip gegeben und in der udm dann auch nochmal als feste ip angegeben.

  • Hallo froesch,


    bei mir sieht das Setup zu 99% identisch aus, bis auf die 2. Fritzbox, das ist bei mir ne gekaufte 7590. Aber ich habe auch eine 7490, die mir die Internetverbindung aufbaut, dann die UDM Pro und dann die FB 7590 am Switch mit ihrem WAN-Port und macht mit 1&1 VoIP. Ich habe außer die Fritzbox auf Clientmodus umzustellen nichts weiter an den VoIP EInstellungen geändert. Und ich muss sagen, das gehört zu den wenigen Anwendungen die mir überhaupt keine Probleme machen!


    Ich habe mit der UDM Pro noch diverse andere Baustellen (s. Threads hier im Forum), aber Telefonie läuft einwandfrei. Wäre auch ein echtes Problem, da eine Tierarztpraxis dran hängt. ;) Mein Frau hätte mir sonst den Hals rum gedreht.


    Hier mal meine Einstellungen:




    Den Sek. DNS Server hat sich die Box selbst eingetragen... die Adresse hat keine Bedeutung.



    Hier mal exemplarisch eine der 1&1 Nummern:



    Ich habe NICHT angeklickt, die Verbindung aktiv zu halten:





    IP V6 hab ich auch deaktiviert. Man muss es ja nicht unnötig verkomplizieren.;)


    Das wars... schon gings... ob es noch funzt, wenn ich mal die UDM Pro einwählen lasse per PPPoE, das wird sich zeigen. Versuchsstart wird heute Abend vermutlich sein. Ich kann wegen der Praxis immer nur an Wochenende solche Späße testen. Hab aus versehen vorgestern im laufenden Betrieb das LAN lahm gelegt. Da gabs mächtig Ärger. ||


    Gruß

    Christian

    UDM Pro V1.9.3.3438, Network V6.2.17, US-16-150W, US-8-60W, USW-Flex, USW-Flex-Mini, UAP-AC-PRO, UAP-AC-Lite, UAP-AC-M

  • also ich habe jetzt sogar die fritzbox, die vor der udm war, aus dem keller geholt. in der sind ja alle telefonnummern eingerichtet und funktionierten.

    einfach mal um auszuschließen, dass vielleicht die andere einen defekt hat.


    geht dennoch nicht. auch hier voip timeout. also so langsam gehen mir die optionen aus... ;(


    Launi du hast nicht mal die portweiterleitung alle 30 sekunden aktiv?

    ja hier drehen auch alle durch, dass andauernd am wochenende das telefon nicht geht ;-) ich bin auch nur an den wochenende zuhause und muß das in der zeit auf die reihe kriegen, oder sonntags alles wieder zurückbauen...

    [email protected] froesch

    -

    UDM-PRO 1.9.0.3413 Controller Version 6.1.61 | USW-PRO-24 5.43.23.12533 | 2x UAP-AC-PRO

    APC Smart-UPS X1500 | Racknex UM-SBC-204 mit Raspi4 8gb | Synology 1815+ | Synology 212j | Fritzbox 7490

  • Ich habe mir noch einmal die Anleitung angeschaut zu easybell


    Weiterhin ist bei diesen Installationen lediglich darauf zu achten, dass die Services SIP-ALG und IGMP-Snooping deaktiviert sind, was die meisten Router für Heim- und Kleinstinstallationen von Hause aus mitbringen.


    Schalte mal das IGMP Snooping aus falls es an ist.