Feste Route einstellen für eine Verbindung ins Heimnetz über Smartphone

  • Hallo,

    ich habe mir vor einigen Wochen einen VPS Server mit Wireguard und zuhause einen Raspberry Pi als VPN Wireguard Gateway eingerichtet. Soweit funktioniert das auch alles. Mit dem Smartphone und meinen Enigma2 Boxen läuft das ganze über den VPS und bekomme auch über utrace die IP vom VPS Server angezeigt.

    Für den externen Zugriff auf mein Heimnetzwerk mit meinem Smartphone, müsste ich eine feste Route einstellen und da scheitert es bei mir. Ich habe schon das ganze probiert, aber bekomme keine Verbindung hin. Habe in der Wireguard Konfiguration mein IP Block meines Heimnetztes eingefügt und sollte dann auch auf Anhieb funktionieren, was es aber nicht tut. Bei einer Fritzbox als Router und feste Route geht es.


    Hat hier jemand eine gleiche Konfiguration und könnte mir Hilfestellung geben?


    LG

  • Stefan71

    Hat den Titel des Themas von „Feste Route einstellen für eine Verbindung ins Heimnetz“ zu „Feste Route einstellen für eine Verbindung ins Heimnetz über Smartphone“ geändert.
  • Mit Wireguard kenne ich mich nicht aus.

    Wenn du aber von außerhalb auf dein Netzwerk zugreifen willst brauchst du entweder DyDNS oder aber dein Internet Anschluss hat eine Feste öffentliche IP.

    Weiterhin wirst du bestimmt Portfreigaben und Firewall Regeln für deinen VPN Server brauchen....... Was meinst du mit "VPS Server"

    Fritzbox UM Kabel

    USG Pro 4, USW Pro 24 Poe Gen2, US-24-250W, US-8, US-8-150W, US8-60W, 5x UAP-AC-Pro u CKG2Plus

  • Ich habe mir bei IONOS einen VPS Server eingerichtet für 1 Euro pro Monat mit Wireguard, das heißt ich kann darüber eine Wireguard Verbindung aufbauen und meine eigentliche IP wird nicht öffentlich sondern nur die IP des VPS Servers von IONOS wird angezeigt. Ich habe Kabel Deutschland/Vodafone mit einer festen IPv4 Adresse. Die Verbindung in meinem Heimnetzwerk funktioniert wunderbar über diese Wireguard Verbindung und auch aus dem mobilen Netz geht das wunderbar. Er verbindet sich dann über diesen VPS Server.

    Von dem ich diese Idee habe hat aber eine Fritzbox und der musste da nur eine feste Route einstellen und kann einfach im Browser eine IP seines Heimnetzes aufrufen z.B. die seiner Enigma2 Box und kommt dann reibungslos auf deren Web Oberfläche.


    Ich habe zu dem Thema eine Anleitung geschrieben ist aber noch Preview und kann sie dir gerne mal zu senden. Eine DynDNS habe ich mir auch schon besorgt, aber weiß nicht wie ich die einsetzen soll.

  • dazu mal ein Link:


    VPS Server


    Der VPS hat 400/400 im Down/Upload und installiert ist Ubuntu und ebenfalls auch auf dem Pi, der ja als GW zählt für die wireguard Verbindung.

    Ich habe ein Technicolor TC4400 Kabelmodem -> USG -> Switch usw. Wobei mittlerweile noch einige AC AP Pro dazu gekommen sind und ein paar Änderungen, ist aber jetzt nicht relevant dafür.


  • Okay, leider kenne ich mich mit dem Technicolor nicht aus.

    Grundsätzlich musst du über Portfreigaben eine Route zu deinem Wireguard einrichten, wohl auf den Raspi.

    Bei der Konfiguration muss ich aber passen, sorry.

    Fritzbox UM Kabel

    USG Pro 4, USW Pro 24 Poe Gen2, US-24-250W, US-8, US-8-150W, US8-60W, 5x UAP-AC-Pro u CKG2Plus

  • Vielleicht bringt mich ja das schon mal weiter mit der Portfreigabe. Aber trotzdem Danke. Vielleicht gibt es ja eine andere Konstellation/Szenario die man anwenden kann und man die gleichen Schritte machen muss und ableiten könnte.

    Aber eine Statische Route muss ich nicht anlegen? Darüber habe ich es letztens probiert und hat aber nicht funktioniert.

  • Das Skript das ich genutzt habe um das einzurichten, legt immer einen anderen Port fest, den weiß ich aber. Ich versuche es mal die Tage. Ich sende dir mal den Link von der Anleitung, dann kannst du dir vielleicht besser ein Bild machen.

  • Stefan71

    So habe deine Anleitung mal durchgelesen, wirklich gut gemacht:thumbup:

    Kleine Anregung: Die Key (auch wenn es nicht deine sind) am besten gegen xxxxx.. ersetzen.

    Und am Anfang solltest du ggf schreiben warum du das so gemacht hast und weshalb der VPS Server


    So habe mich mal schlau (hoffentlich) gemacht:

    zum einen benötigst du eine Portweiterleitung


    und vielleicht noch ne WAN Local regel


    Hoffe das hilft dir, die Richtung sollte aber schon einmal stimmen


    ps:

    Dein Kabelmodem sollte natürlich im Bridge Mode sein, ansonsten musst du die Portfreigabe mit Routing an die UDM auch im Modem umsetzen.

    Fritzbox UM Kabel

    USG Pro 4, USW Pro 24 Poe Gen2, US-24-250W, US-8, US-8-150W, US8-60W, 5x UAP-AC-Pro u CKG2Plus

    Einmal editiert, zuletzt von BlackSpy ()

  • Hi,

    super und Danke für das Feedback. Das mit den Schlüssel, die sind aus einer anderen nicht mehr gültigen Konfig, aber werde es so machen mit dem X-en. Heute morgen nach dem Nachtdienst hatte ich das mit der Port Weiterleitung noch versucht, aber das ging nicht, zumindest nicht mit den Daten die ich benutzt habe. Schaue mir deine Fotos gleich an und lege die Regeln so an.

    Das Modem ist im Bridge Modus, deshalb hatte ich damals meine gemietete Kabel Fritte zurück gegeben.


    Danke für deine Mühe und Zeit.

  • Nein ist eine WAN Local Regel.

    Ich mache alles in der klassischen Ansicht, wie es bei dem modernen Klickbunti ausschaut kann ich dir nicht sagen.

    Am besten kurz zur Classic wechseln und später kannst du wieder zurück auf das bunte

    Fritzbox UM Kabel

    USG Pro 4, USW Pro 24 Poe Gen2, US-24-250W, US-8, US-8-150W, US8-60W, 5x UAP-AC-Pro u CKG2Plus

  • Hallo,

    ich habe mir vor einigen Wochen einen VPS Server mit Wireguard und zuhause einen Raspberry Pi als VPN Wireguard Gateway eingerichtet. Soweit funktioniert das auch alles.

    ist das korrekt das die Wireguard Verbindung steht? dann sind die Portfreigaben schon korrekt und nicht das Problem.


    wenn keine Verbindung zum LAN besteht und der Raspi das Wireguard Gateway in deinem Netz ist, sollte dort mal die Firewall geprüft werden ob die evtl. den Zugang zum Lan blockiert.

  • ist das korrekt das die Wireguard Verbindung steht? dann sind die Portfreigaben schon korrekt und nicht das Problem.


    wenn keine Verbindung zum LAN besteht und der Raspi das Wireguard Gateway in deinem Netz ist, sollte dort mal die Firewall geprüft werden ob die evtl. den Zugang zum Lan blockiert.

    Wenn ich die Wireguard Verbindung auf dem Smartphone aktiviere und mich in dem eigenen WLAN und einem externen WLAN mich bewege und im Internet unterwegs bin, teste ich mit utrace und bekomme die IP des VPS Servers angezeigt. Deaktiviere ich die WG Verbindung zeigt er mir die IP des Providers an. Wenn ich auch auf meinen VU+ Boxen die externe IP teste, zeigt er mir auch die vom VPS Server an. Deshalb denke ich das alles soweit richtig eingerichtet ist. Ich habe da auch in der WG config den IP Block meines Heinetzes eingefügt.


    Es hakt halt nur der Eintritt von extern auf mein Heimnetz.


    BlackSpy

    Habe jetzt die Regel nach deinen Fotos angelegt und komme nicht über das mobile Netz auf mein Heimnetz.

    Jetzt habe ich auch festgestellt bei aktivierter WG Verbindung und im eigenen WLAN habe ich auf dem Smartphone keinen Zugriff auf Geräte aus dem Heimnetz mehr. Vorher ging das