Herausforderung feste IP Vergabe & Portfreischaltung

  • Hallo zusammen,


    zuerst einmal hoffe ich, dass ich im richtigen Bereich bin o_O Falls nicht sorry!


    Ich habe zwei Herausforderungen welche ich aktuell nicht lösen kann.


    Herausforderung 1:

    Ich möchte meinem Windows 11 PC im Lan Adapter eine feste IP Adresse zuweisen. Sobald ich diese hinterlege, habe ich keine Internetverbindung mehr an diesem PC (intern alles möglich). Ich habe versucht die gleiche aus dem DHCP Bereich zu nehmen, welche er bereits bekommen hat. Des Weiteren habe ich auch eine freie Adresse aus dem DHCP Bereich versucht und eine, welche nicht im DCHP Bereich liegt. Jedes mal erfolglos. Wenn ich die feste IP auf der UDM vergebe funktioniert das. Auch hat meine FritzBox (Client Modus), meine Synology Nas und der DrayTek Vigor166 feste Adressen. Dort funktioniert alles ohne Probleme und die Geräte z.B. Nas kommt nach außen.

    Die Verbindung zu meinem Windows Client ist wie folgt: UDM PRO - "dummer" TP Link Switch - PC.

    Eine weitere Frage hierzu wäre, bei den Endgeräten wird immer automatisch die Benutzergruppe "auf WLAN Benutzergruppe zurücksetzen" hinterlegt und nicht die "default". Was hat das für Auswirkungen?


    Herausforderung 2:

    Ich habe mir für die Sicherung meiner Nas bei Hetzner eine Storage Box gemietet. Auf diese möchte ich via RSYNC meine NAS Daten sichern. Ich habe gelesen, dass der RSYNC Port 873 ist. Jedoch gibt Hetzner bei sich den Port 23 an. Wie ist hier vorzugehen? Laut Portchecker sind bei mir beide Ports geschlossen. Ich habe auch schon versucht, diese in der UDMP freizuschalten, leider ohne Erfolg. Hat hier jemand einen Tipp?


    Aktuell befinden sich alle meine Geräte im gleichen Netz = LAN auch wenn die zukünftigen VLANs schon angelegt sind. Im Anhang noch ein paar Screenshots meiner Konfiguration.


    Vielen Dank für die Unterstützung.


    Andi

  • Sobald ich diese hinterlege, habe ich keine Internetverbindung mehr an diesem PC (intern alles möglich).

    Das deutet darauf hin, dass Du falsches Gateway hinterlegt hast.



    Ich habe mir für die Sicherung meiner Nas bei Hetzner eine Storage Box gemietet. Auf diese möchte ich via RSYNC meine NAS Daten sichern.

    Läuft da auch der rsync Daemon?

  • Das deutet darauf hin, dass Du falsches Gateway hinterlegt hast.

    Als Gateway habe ich die UDM P hinterlegt. Daher die 192.168.1.1


    Läuft da auch der rsync Daemon?

    Gute Frage, muss man diesen bei Hetzner erst aktivieren lassen? Ich check das mal gegen. Merci

    Einmal editiert, zuletzt von razor () aus folgendem Grund: Ein Beitrag von AndresFrank mit diesem Beitrag zusammengefügt.

  • zu 1:

    hast du auf alles auf dem Windows-PC konfiguriert:

    • IP-Adresse
    • Subnetz
    • Gateway
    • DNS-Server ?

    Ich vermute, eines davon fehlt.


    Entweder alles fest eintragen oder per DHCP von der UDM verteilen lassen, dann eben dort ,mit IP-Reservierung



    zu 2: RSYNC arbeitet per Default auf port 22 (ssh-Port), Hetzner nutzt Port 23, ist aber egal, das muss du dem rsync-Kommando eh mitgeben.


    Ich nutze auch Rsync zu Hetzner und habe da garnichts freigeschaltet, alle Verbindung nach aussen sind offen.


    Du musst aber bei Hetzner in dem Robot für deine StorageBox "ssh" aktivieren, sonst funktioniert das nichts

  • Als Gateway habe ich die UDM P hinterlegt. Daher die 192.168.1.1


    Und Du bist sicher, dass der Rechner auch aus dem Bereich 192.168.1.0 eine IP bekommt wenn er DHCP macht?


    Gute Frage, muss man diesen bei Hetzner erst aktivieren lassen?

    So fern die das überhaupt anbieten - ew ja..

    Und dann ist wohl Sinnvoll per ssh die Sachen zu schieben. Port 23 ist wenn ich nicht ganz falsch liege telnet == böse

  • Servus Tuxtom007, vielen Dank für deine Hilfe, dass war auch schon die Lösung zum 1. Problem.

    Warum ich den DNS-Server auch angeben muss ist mir neu. War bei der Fritze nicht so. Habe diesen auch hinterlegt und dann klappt es auch.


    Zu dem Problem mit Hetzner:


    RSYNC ist dort aktiv, allerdings kann das RSYNC Kommando dort nicht steuern, da es über Hyper Backup (ein Backuptool von Synology) läuft...

    Einmal editiert, zuletzt von razor () aus folgendem Grund: Ein Beitrag von AndresFrank mit diesem Beitrag zusammengefügt.

  • Warum ich den DNS-Server auch angeben muss ist mir neu.

    Wie soll denn sonst die Namensauflösung funktionieren?



    allerdings kann das RSYNC Kommando dort nicht steuern, da es über Hyper Backup (ein Backuptool von Synology) läuft...

    Das verstehe ich nicht. Was kann was nicht steuern?

    Du setzt die Befehle zum Syncen lokal ab. Wenn das so ist wie Tuxtom007 schreibt, wirst Du in der Befehlskette auch den Port mitgeben müssen

  • Servus Tuxtom007, vielen Dank für deine Hilfe, dass war auch schon die Lösung zum 1. Problem.

    Warum ich den DNS-Server auch angeben muss ist mir neu. War bei der Fritze nicht so. Habe diesen auch hinterlegt und dann klappt es auch.

    Der DNS-Server wird normaler per DHCP verteilt, wenn du feste IP-Adressen einträgt, musst du eben auch alles eintragen, was sonst per DHCP kommt, eben auch DNS

    Das verstehe ich nicht. Was kann was nicht steuern?

    Du setzt die Befehle zum Syncen lokal ab. Wenn das so ist wie Tuxtom007 schreibt, wirst Du in der Befehlskette auch den Port mitgeben müssen

    Achso, ich nutze kein Tool auf meiner QNAP nicht, sondern mache das per Shell-Script, welches nacheinader alle Sync-Jobs abarbeittet, gestartet per Cron-Job.

    QNAP hat auch so ein Cloud-Backuptool, ist der letzte Mist und hat schon bei Strato nicht funktioniert.

    EDIT: gerade mal auf meiner QNAP geschaut, das HyberSync Backuptool erlaubt es bei mir, den Port einzustellen.

    Ziel RSYNC-kompatibler Server, dann Benutzer/PAssword und Hostname + Port eintragen

  • Ich verstehe die Fragestellung zu RSYNC nicht ganz.


    Du erstellst im DSM deine Backupaufgabe und gibst dort alle Daten an welche, in deinem Fall Hetzner, benötigt werden.

    Dort stellst du auch den Port ein, also:


    DSM > Hauptmenü > Hyperbackup > neues Fenster > links oben auf das weise Pluszeichen im blauen Rechteck klicken > neues Fenster > Alle benötigten Daten eintragen:



    Weiter > den weiteren Anweisungen folgen.


    Wenn du hingegen deine Diskstation selbst als "Ziel" verwenden möchtest, dann musst du diese Funktion freischalten:


    DSM > Hauptmenü > Systemsteuerung > Dateidienste > Register "rsync" > rsync-Dienst aktivieren, Port definieren > rechts unten auf "Übernehmen" klicken, sonst werden deine gerade getätigten Einstellungen nicht übernommen:



    Wie gesagt, für den Fall falls du deine Diskstation selbst als "Ziel" verwenden/zur Verfügung stellen möchtest.

  • Die roten Rahmen zeigen eine noch fehlende Eingabe an, also da fehlt noch das Backupmodul und das Verzeichnis.

    So lange diese Daten nicht eingetragen sind, kann HB diese Backupaufgabe nicht starten.

    Das Backupmodul ist der freigegebene Ordner welchen du bei Hetzner angelegt hast.

    Das Verzeichnis ist dann ein Unterordner von diesen freigegebenen Ordner.

    Bei Port 23 sollte passen in diesem Fall. Port 23 darf nicht blockiert sein.

    Sicherstellen dass die Firewall die nicht blockt.

    Wenn du auf das schwarze Dreieck bei Backupmodul klickst, dann sollten die möglichen Ordner die dir bei Hetzner zur Verfügung stehen in der öffnenden Tabellenansicht ausgewählt werden können.


    Soweit ich es Verstanden habe solltest du bei Hetzner den Ordner /home angezeigt bekommen nur dieser soll beschreibbar sein.

    Nicht verwechseln mit dem Home-Ordner auf deiner Synology!


    Siehe dazu auch:

    https://docs.hetzner.com/de/ro…box/backup-space-ssh-keys


    https://docs.hetzner.com/de/ro…ess/access-ssh-rsync-borg


    Wenn das alles nicht hilft, dann schau mal hier:

    https://www.synology-forum.de/…etzner-storage-box.97757/


    Port23 war damals richtig. Aber schau dir die Bilder am Besten selber an im Beitrag.