Remote User VPN - Verbindung fehlgeschlagen - Fehleranalyse

  • Hallo zusammen,


    ich hab bereits aufmerksam alle verwandten Threads im Forum durchforstet und viele tolle Tipps gefunden. Leider konnte ich damit mein VPN noch nicht zum Laufen bringen. Deshalb nun ein eigener Thread. Mit meinem Latein bin ich am Ende und bin daher auf der Suche nach Tipps, wie ich bei der Fehlersuche vorgehen könnte.


    Zuerst das Setup:

    Ich habe ein Vigour 165 als Modem vor meiner UDM-Pro. Die Einwahl ins Internet übernimmt die UMD. Client soll ein Smartphone mit Android 11 sein (VPN-Verbindung mit den Androidboardmitteln)


    Wie habe ich das VPN eingerichtet?

    Altes UI -> Radius Server erstellt (Secret vergeben, ansonsten Standardeinstellungen) -> User angelegt (Name und Passwort vergeben, ansonsten Standardeinstellungen) -> Netzwerk hinzugefügt (Name vergeben, "Remote User VPN", Pre-Shared-Key vergeben, Ip-Bereich vergeben, Radius-Profil zugewiesen, ansonsten Standardeinstellungen). Die passenden Screenshots hab ich angehangen.


    Folgende Tipps hab ich schon gelesen und getestet:

    • Haken bei Radius-Einstellungen "Configure clients sectiion for whole network" gesetzt: Das hab ich einmal mit dem Chrome-dev-tools versucht und die UDM nochmal auf Werkseinstellungen zurückgesetzt und die Einrichtung mit dem alten UI durchgeführt. Der Haken ist nun gesetzt (siehe Screenshot).
    • Unterschiedliche Passwörter.
    • Der Verbindungsversuch wird immer aus das Mobilfunknetz durchgeführt (Bin als nicht im Unifinetz, in das die Verbindung aufgebaut werden soll)

    Leider lässt sich das VPN auf dem Android-Smartphone nicht aufbauen. Es kommt stets die Meldung "Nicht erfolgreich". Mehr Infos erhalte ich leider nicht. Daher habe ich leider auch keinen Ansatzpunkt, um den Fehler zu suchen. Erreicht mein Smartphone überhaupt die UDM? Gibt es Probleme mit den Userdaten? Wird die Verbindung bereits woanders geblockt? Wo und wie kann ich dazu passende Logs einsehen?


    Wie kann ich die Fehleranalyse strukturiert starten? Könnt ihr mir dabei weiterhelfen?

  • Ich habe ähnliche Konfig.

    Beim User musste du Tunnel Typ und Medium angeben.

    Ich habe 13 Virtuelles LAN und 6 802

    Andere haben auch 3 und 1.

    Beim Netzwerk MSChap V2 aktivieren.

    Die Android Einstellungen sehen gut aus.

  • Vielen Dank für die schnelle Rückmeldung. Ich habe deine Vorschläge getestet:

    • MSChapV2 unter Netzwerk aktiviert
    • User Tunnel Typ auf 13 und Tunnel Medium auf 6

    Leider hat es damit nicht geklappt. Deswegen habe ich noch die zweite Konfig

    • MSChapV2 unter Netzwerk aktiviert
    • User Tunnel Typ auf 3 und Tunnel Medium auf 1

    getestet. Damit klappt es leider auch nicht.


    Hat noch jemand eine Idee, wie ich prüfen kann, ob die VPN Anfrage des Smartphones überhaupt an dem UDM ankommt?

  • Wenn ich ICMP in der Unifi Firewall freischalte (wie in dieser Anleitung beschrieben UDMP antwortet nicht auf Ping) kann ich meine WAN-IP direkt und über DynDNS von außen anpingen. Mein Provider ist dslmobil. Mir ist nicht bekannt, dass ds-lite verwendet wird.


    Gibt es Einschränkungen bei der Nutzung von Diensten über das Internet (FTP, Web, Telnet etc.)?

    Nein. Wir sperren oder beschränken keine Ports oder Adressen. Alle IP-basierten Anwendungen sind grundsätzlich nutzbar.

    Andere Systeme, wie z.B. Synology können über deren Cloud zum Beispiel auf mein NAS zugreifen. Das VPN bleibt leider weiter still.

  • Vielleicht blockt dein Vigor was weg, kenne mich damit aber nicht aus.

    Du hast wohl alles über die alte GUI des Controller gemacht? Einigen hat geholfen dies in der alten GUI zu löschen und in der neuen GUI wieder anzulegen.

  • Ich habe schon die alte und neue GUI getestet. Zuerst hatte ich es mit der neuen GUI erstellt. Das hatte leider nicht funktioniert. Dann habe ich gelesen, dass man es nur mit der alten GUI erstellen soll. Das hat mich bislang leider schon sehr viel Zeit gekostet, da ich zwischenzeitlich die UDM komplett neu aufgesetzt hatte, weil es hieß, dass das VPN initial nur mit der alten GUI erstellt werden muss. Am Ende funktioniert es leider weder noch (egal ob mit neuer und mit alter GUI). Das Vigour ist bei mir als reines Modem installiert. D.h. es sollte eigentlich nichts selektieren.

  • Sorry, kann ich so leider auch nicht weiterhelfen.

    Bei meiner UDM Pro, Vodafone Business Kabel und einer Fritzbox funktioniert es ohne Probleme, selbst mit doppelten NAT.

    Die Fritzbox ist auch nicht im Bridge Mode und übernimmt die Einwahl.

    Einzig die VPN Ports musste ich separat frei geben, trotz exposed Host.

    Nicht zufällig im Vigor noch irgendein VPN konfiguriert?, die Frage daher das selbst wenn eine Fritzbox im Bridge Mode ist, aber ein User dort mit VPN angelegt ist, die Fritte die VPN Anfragen abgreift und nicht weiter leitet, womöglich hat das Vigor ähnliches Verhalten.


    Gibt aber auch einige hier die gleiche Konstellation haben wie du und dort geht es, jemand wird sich bestimmt melden und dir behilflich sein.

  • Ich konnte den Fehler nun finden. Es lag nicht an der UDM Konfig. Problem ist das Smartphone. Ich habe ein Motorola One Vision. Dort gibt es den Bug in der Software, dass VPN nicht richtig funktioniert, sobal Wifi-Calling in den Einstellungen aktiv ist. Mit deaktiviertem Wifi-Calling. Läuft alles ...


    Dennoch vielen Dank für die Unterstützung bei der Fehlersuche.

  • TomUDM

    Hat das Label von offen auf erledigt geändert