Regelmäßiges "offline" bzw. Verbindungsabbruch

  • Hallo zusammen,

    wie auf dem unten angefügten schematischen Bild zu erkennen ist, setze ich mehrere Unifi-Produkte ein.

    Auf der USG sind diverse VLANs eingerichtet, sodass ich in meinem LAN Komponenten wie Smarthome, Office, Beruf und mobil. etc. voneinander trennen kann. Ebenso wurden hierzu Firewallregeln, wenn auch nur ein paar, implementiert.

    Ehemals vollwertige Fritz!Boxen werden "nur" noch als Telefonanlage verwendet. Und hier bin ich auch schon bei meinem ersten Problem. Hin und wieder "steigt" meine Telefonie aus, sodass ich weder ein- noch ausgehende Anrufe tätigen kann. Als würde sich die Fritz!Box "aufhängen".

    Ob diese "Hänger" mit meiner Netzwerkkonfiguration (VLANs, Firewall) zu tun haben wage ich zu bezweifeln, möchte es jedoch nicht vollends ausschließen. Zumal ich hin und wieder einen Disconnect meiner Endgeräte in Richtung Internet feststelle.

    Anfänglich habe ich es auf die Zwangstrennung geschoben, aber nach dem ich die Konfiguration an dem Draytek-Modem überprüft und dort eine keine eingestellte Zwangstrennung feststellen konnte, bin ich etwas ratlos.

    Auf der USG ist der Zugang zum Provider (hier: 1&1) als PPPoE konfiguriert (also mit H vor der Kennung und ohne VLAN ID).

    Das USG versorgt alle eingerichteten VLANs mit DHCP-Adressen und besitzt selbst die x.y.z.1 als IP, hingegen das Draytek-Modem die x.y.z.2.

    Das Ganze Unifi-Netzwerk wird durch einen Controller auf Ubuntu-Basis verwaltet (dieser ist auch in dem Schaubild ersichtlich).


    Ich weiß dass dort ebenso erkennbar ist, dass ein Switch "nur" mit 100Mbit angebunden ist. An diesem befindet sich unter anderem auch eine der Fritz!Boxen. Jedoch "schiebe" ich auch hier nicht der kleineren Bandbreite die Netzwerkabbrüche zu, da sie an einer anderen Fritz!Box an einem anderen Switch (1Gbit) ebenso stattfinden.


    Alle Unifi-Endgeräte haben den derzeit aktuellsten Firmwarestand (laut Controller).


    Ich hoffe nun auf das geballte Schwarmwissen und das ggf. der ein oder andere hilfreiche Tipp dabei ist, der mein "Problem" lösen kann.


    Wenn noch mehr Informationen benötigt werden, so lasst es mich wissen.


    Vielen Dank schon mal!

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"

  • Hast du mal wenn ein Verbindungsabbruch war nen trace laufen lassen und geschaut ab welchem Punkt der Trace nicht mehr weiter kommt?

    Danke für den Tipp. - ich versuche ihn zu beherzigen.

    Das Problem ist nur, dass es leider nicht vorhersehbar ist wann der Verbindungsabbruch passiert. Es kam mitunter schon vor, dass ich unterwegs war, wollte zuhause anrufen und merkte dass sämtliche Rufnummer nicht erreichbar waren. Es passierte aber auch schon, während ich am Rechner saß.


    Ich habe gestern hier noch etwas im Forum gestöbert und bin auf wertvolle Tipps in Punkto Firewallregeln gestoßen. Diese habe ich dann gestern, oder eher heute, bis 00:30 Uhr implementiert bzw. auf meine "Bedürfnisse" angepasst.

    Ich werde jetzt mal das ganze Setup beobachten und mal schauen wie es nun um die "Verbindungsabbrüche" steht. Ferner habe ich unter dem Setting "Routing & Firewall > Firewall > Settings > CONNTRACK MODULES " die Option "SIP" gefunden. Diese ist per default auf "OFF".

    Da ich meine Rufnummern via VoIP funktionieren, habe ich die Option mal eingeschaltet. Ob das oder die neuen Firewallregeln wirklich zielführend sind, gilt es nun zu prüfen.

    "Ich bleibe am Ball", freue mich aber dennoch über weitere Tipps und Anregungen!

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"

  • Das Contrack Modul sollte immer auf aus stehen, ist eher kontra produktiv was VOIP angeht. Verstehe ich das richtig das es nur die Fritzbox mit VOIP betrifft und nicht das Internet ansich? Welche Ports hast Du zur Fritzbox weitergeleitet? Wie ist die Fritzbox eingerichtet? Poste am besten mal Screenshots.

  • jkasten: Vielen Dank für Deine Denkanregungen!


    Meinst Du das Contrack Modul an sich (also alle Einstellungen) oder nur den Punkt welcher "SIP" betrifft.

    Ich glaube, dann habe ich mich unglücklich ausgedrückt und versuche ein paar Hintergrundinformationen zu geben.

    Ich arbeite derzeit von zuhause aus und diese Verbindung läuft via VPN. Telefonie läuft bei mir über eine, der vom Provider zugeteilten VoIp-Rufnummern. - Soweit so gut.

    Mir ist nur hin und wieder aufgefallen, dass die via VPN-Tunnel aufgebauten Verbindungen abgebrochen sind und keine Verbindung zum "Firmennetzwerk" bestand. Zufällig geführte Telefonate brachen ab.

    Diese Abbrüche traten unterschiedlich auf. Das heißt mal morgens gegen 11:00 Uhr, aber auch mittags um 16:00 Uhr oder kurz vor 17:00 Uhr zum Beispiel. Manchmal merkte ich es auch daran, dass ich unterwegs war und via Handy keine meine Rufnummern erreichen konnte. Es wurde einfach kein Ruf aufgebaut.

    Stellte ich das Problem mit dem Telefon fest half oft ein Aus- und Einschalten der Fritz!Box.


    Die beiden Fritz!Boxen (1x private Telefonie (2 Rufnummern [Tel]), 1x berufliche Telefonie (2 Rufnummern [Tel, Fax])) sind als IP-Client eingerichtete Fritz!Boxen (1x FB7530 (priv), 1x FB 7490 (berufl.)).


    Ich habe keine Ports dediziert weitergeleitet. Lediglich in den Telefonieeinstellungen der jeweiligen Fritz!Box habe ich die Option "Portweiterleitung des Internet-Routers für Telefonie aktiv halten (30 Sek.)" eingestellt. Ich habe mich hierbei an ein paar Einstellungstipps und Konfigurationsempfehlungen, welche ich im Internet gefunden habe, orientiert. Weiterhin befinden sich die Fritz!Boxen in dem gleichen VLAN wie die übrigen, zentralen Komponenten.


    Noch aber ein Hinweis: Seit der Umstellung der Firewallregeln am Dienstag, wie oben von mir beschrieben, sind mir die Abbrüche sei es Internet und/ oder Telefonie nicht mehr aufgefallen.


    Ich bin aber gerne bereit, sofern erforderlich und sinnvoll mein Netzwerksetup weiter zu verändern um ggf. Engpässe zu beseitigen und oder "schlummernden" Problemen vorzubeugen.

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"

  • Ok verstehe, es kann durchaus sein das sich die zwei Fritzbox da behaken. Warum richtest du nicht alle Nummern in der gleich Box ein oder nutzt eine PBX wie 3CX zum Beispiel. Der SIP Port ist standardmäßig 5060 und wenn beide Boxen versuchen sich zu registrieren, kann das schwierig werden. Was die Contrack Module angeht, meinte ich nur das SIP.

  • jkasten: Danke für die Info.

    Ich verstehe nur nicht ganz warum sich die beiden Fritz!Boxen behaken sollten, denn die eine Fritz!Box kennt die Rufnummern, geschweige denn die Endgeräte der anderen überhaupt nicht (und umgekehrt ebenso).

    Das IP-Telefon könnte ich durchaus noch auf die andere "private" Fritz!Box umziehen. Bei dem Fax wird es allerdings problematisch, da dieses via TAE angeschlossen ist und ich keine "(Telefon)Kabelverbindung" zu der anderen, privaten Fritz!Box habe.

    Ich werde mal weiter Fehlersuche betreiben, aber den "SIP-Schalter" im Contrack Module wieder ausschalten.

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"

  • Da beide Boxen versuchen über den SIP Port 5060 raus und rein zu gehen. Geht aber nur einmal.

  • So, ich habe das jetzt mal das Telefonsetup geändert. Das heißt alle VoIP-Nummern sind auf einer Fritz!Box registriert und alle Telefone "arbeiten" über die 7530.

    Für die Fax-Funktion versuche ich mal die interne Fax-Weiterleitung via E-Mail der Fritz!Box.

    Mal schauen on jetzt die "Telefonaussetzer" verschwunden sind. - Ich werde berichten.


    Danke nochmal für die Unterstützung bzw. die Tipps/ Denkanstöße.

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"

  • Gerne und bitte um Rückmeldung ob das die Lösung war.

  • Also,... meinem Empfinden und Erfahrungen nach läuft das ganze Konstrukt jetzt "runder" als vorher.

    Allerdings wurde mir gestern berichtet, dass während eines Telefonats wieder das Gespräch unterbrochen wurde.

    Parallele Internetaussetzer kann ich nicht bestätigen.

    So langsam habe ich eine wenig die Fritz!Box in Verdacht. Es handelt sich dabei um das Modell 7530, welches allerdings vom Provider gestellt und durch mich zurückgesetzt und als IP-Client konfiguriert wurde.

    Das Problem ist nur, würde ich auf eine andere "Telefonanlage", zum Beispiel Siemens N510 IP Pro umstellen, müsste ich auch die Endgeräte tauschen. Denn nach meinem Sachstand sind Fritz!Fon-Apparate nicht damit kompatibel (umgekehrt jedoch schon).

    Viele Grüße


    ssd376

    -----------------------------------------------------

    "Machen ist wie wollen, nur krasser!"