UAS-XG unboxed & pimped-up

Es gibt 25 Antworten in diesem Thema, welches 964 mal aufgerufen wurde. Der letzte Beitrag () ist von Grendelbox.

  • Hallo zusammen.


    heute geht um das Pimp-Up eine UAS-XG UniFi Application Servers

    welcher zugegen halt schon wieder leider in die Tage gekommen ist,

    trotzdem immer noch ein ziemlich geiles Stück Hardware.


    1806977-l0.jpg


    1806977-l1.jpg


    1806977-l2.jpg



    Ubiquiti UniFi XG Application Server | Preisvergleich Geizhals Deutschland
    ✔ Preisvergleich für Ubiquiti UniFi XG Application Server ✔ Produktinfo ⇒ Typ: Controller… ✔ Zubehör ✔ Testberichte ✔ Günstig kaufen
    geizhals.de


    Kurzanleitung UAS-XG

    Ubiquiti - Simplifying IT
    Technology platforms for Internet Access, Enterprise, and SmartHome applications.
    www.ui.com


    unknown.png



    Nach UI Werksreset:

    Username: ubnt

    Passwort: ubntserver


    unknown.png



    unknown.png


    Nix Deutsch....



    unknown.png


    unknown.png



    Standardmäßig ist ein Ubuntu 16.04 LTS im UI Unterbau installiert.


    !!! EIN UPDATE auf aktuelles Ubuntu wird im Internet NICHT empfohlen. !!!


    unknown.png


    unknown.png


    unknown.png


    dito wieder...


    Username: ubnt

    Passwort: ubntserver



    unknown.png

    Jeweils recht oben auf das gelbe UPGRADE klicken....


    unknown.png


    Die UAS-XG kann auch als Controller für
    UCRM und UNMS dienen




    Standardmäßig verbaut


    120GB m.2 SATA 2280 SSD als Bootmedium

    2x 2TB 3.5" HDDs (bei mir von Hitachi)


    unknown.png


    IMG_2613.jpg


    Die HDD Einschübe...


    IMG_2614.jpg


    2,5" HDDs / SSDs mit Hilfe dieser Teile hier funktionell einzubauen kann man allerdings vergessen....passt nicht


    IMG_2615.jpg


    Meine Empfehlung deshalb:

    https://www.amazon.de/gp/product/B07QVX8TWJ


    Zum BMC des UAS-XG


    Im Kern des Gerätes werkelt ein normales Mini-ITX Serverboard von SUPERMICRO
    Daher ist auch ein BMC mit AST2400 Chip onboard vorhanden und per 1G RJ45 via DHCP erreichbar


    unknown.png


    unknown.png


    unknown.png


    Etwas unlogisch ist das setzen der NTP TIme


    unknown.png


    weil damit man hier im BMC auf die für Deutschland richtige Timezone auswählen kann
    und die Zeit dann auch stimmt
    muss zuerst die Timezone im Webportal der UAS-XG gesetzt werden.

    unknown.png


    danach kann man im idrac auch auf +2Hrs bei NTP einstellen ...

    LOGISCH ist das ganze nicht wirklich

    Denn das IDRAC sollte eigentlich NIX mit dem Host OS und dessen Settings zu tun haben.


    unknown.png

    Einmal editiert, zuletzt von razor () aus folgendem Grund: Ein Beitrag von Grendelbox mit diesem Beitrag zusammengefügt.

  • IMG_2624.jpg


    IMG_2625.jpg


    M.2 2280 Slot mit der originalen 120GB m.2 SATA SSD


    IMG_2626.jpg


    getauscht gegen eine


    m.2 NVMe v1.4 PCIe 3.0 x4 von WD (SN550 500GB)


    IMG_2627.jpg


    Der Lüfter unter dem Lüftungskanal für den Passiven CPU SOC Kühlkörper


    IMG_2628.jpg


    Es sind 3 Stück 40x20mm Lüfter verbaut...
    diese wurden durch Noctua's getauscht


    IMG_2629.jpg


    IMG_2630.jpg

  • Zum MiniITX-Motherboard von SuperMicro


    Verbaut ist ein Board der X10 Serie



    SuperMicro X10SDV-4C-TLN2F


    Supermicro X10SDV-4C-TLN2F retail | Preisvergleich Geizhals Deutschland
    ✔ Preisvergleich für Supermicro X10SDV-4C-TLN2F retail ✔ Produktinfo ⇒ Formfaktor: Mini-ITX • CPU: Intel Xeon D-1520, 4C/8T, 2.20-2.60GHz, 6MB+1MB Cache, 45W…
    geizhals.de


    Link von SuperMicro zum Board:
    https://www.supermicro.com/en/…therboard/X10SDV-4C-TLN2F



    Formfaktor Mini-ITX

    CPU Intel Xeon D-1520, 4C/8T, 2.20-2.60GHz, 6MB+1MB Cache, 45W TDP, Codename "Broadwell-DE" (Broadwell, 14nm)

    Chipsatz System-on-Chip (SoC)

    RAM 4x DDR4 DIMM, dual PC4-17000R/DDR4-2133, max. 64GB (UDIMM), 128GB (RDIMM)

    Erweiterungsslots 1x PCIe 3.0 x16, 1x M.2/M-Key (PCIe 3.0 x4/SATA, 2280/2242)

    Anschlüsse extern 1x VGA (AST2400), 2x USB-A 3.0 (5Gb/s), 2x 10GBase-T (SoC), 1x Management-Port (RJ-45)

    Anschlüsse intern 2x USB 2.0 Header (480Mb/s, 4x USB 2.0), 6x SATA 6Gb/s (D-1520), 1x seriell, 1x TPM-Header

    Header Kühlung 3x CPU-Lüfter 4-Pin

    Header Beleuchtung N/A

    Audio N/A

    Grafik ASPEED AST2400 (Onboard)

    Wireless N/A

    RAID-Level N/A

    Multi-GPU N/A

    Stromanschlüsse 1x DC-In (12V), 1x 24-Pin ATX, 1x 4-Pin ATX12V, 1x 4-Pin Molex

    Beleuchtung N/A

    Besonderheiten All solid capacitors, IPMI 2.0, passiv gekühlt, ECC-Unterstützung


    Mein BIOS Stand war v1.3


    unknown.png


    Mein BMC Stand war v 3.6.8



    hier diverse BIOS Settings


    unknown.png



    der X16 Slot könnte sogar Bifurcation


    unknown.png


    unknown.png


    unknown.png


    mit den BIOS Settings ab Werk kann man KEIN WINDOWS OS

    auf einer NVMe installieren


    unknown.png



    an dieser Stelle habe ich erst einmal die BMC Firmware von 3.6.8 auf 3.8.8

    und das BIOS von 1.3 auf 2.3 upgedated.

    Bitte immer erst das BMC Flashen und DANN das BIOS danach

    Umgedreht ging es bei mir nicht.


    beide Updates gibt es hier:
    https://www.supermicro.com/en/…therboard/X10SDV-4C-TLN2F


    Für ein Update via BMC GUI braucht man einen Activation Code von SuperMicro

    wer den nicht hat....Alternative Methode via DOS Boot Stick ect. pp. !


    unknown.png


    unknown.png



    Bei den Updates SEHR VIEL GEDULD mitbringen und einfach machen lassen

    AUF KEINEN FALL - Selbst wenn das Gerät nicht mehr reagieren sollte - REBOOTEN.
    Irgendwann wird das schon fertig und das Gerät meldet sich wieder.


    WICHTIG !!!

    1) Beim BMC Update via GUI bitte ZWINGEND den ersten HAKEN rausnehmen !!!!



    2) Beim BIOS Update die Haken SO lassen...

    unknown.png



    Voila.....BIOS v2.3 :smiling_face:


    unknown.png

  • KJL

    Hat das Thema freigeschaltet.
  • Blockdiagramm des Mothernboards


    unknown.png

  • Um Windows OS zu installieren MUSS MAN ALLE EBENEN im BIOS auf (U)EFI einstellen

    Mit LEGACY und DUAL bekommt man kein Windows auf der NVMe bootfähig installiert.


    unknown.png!!!


    unknown.png   !!!


    unknown.png


    Gewonnen ! Kein "Gemecker" mehr von Windows ! :thumbs_up::smiling_face_with_sunglasses:


    unknown.png


    unknown.png


    :smiling_face_with_sunglasses:


    unknown.png


    unknown.png


    die 2 Onboard 10GbE NICs gleich mal 20GbE Teamen ...LACP Dynamisch

    damit es mit dem aggregrieren auf dem Switch auch passt.



    unknown.png



    Verbaut ist ein Intel Dualport NIC Chip


    unknown.png



    Nach Installation von 68 neuen bzw fehlenden Treibern


    unknown.png


    endlich....Gerätemanager Impressionen :winking_face_with_tongue:


    unknown.png



    Temperatur der CPU (Deckel offen)


    unknown.png


    LEIDER hat das Fremdinstallieren für die quadratische Power LED mit dem UI Logo einen Haken..
    Das Ding blinkt nervig DAUER

    ich habe mir erstmal damit beholfen den folgenden GPIO Stecker vom LED Board abzuziehen.



    unknown.png

  • unknown.png


    HW INFIO 7.22


    unknown.png



    Ein TPM-Modul 20pin Module läßt sich auf dem Motherboard nachrüsten

  • Server 2022

  • unknown.png


    unknown.png

    Vielleicht ist dieser Link für dich interessant:


    Wer googelt findet eine passende Lösung (edit by defcon)

  • Standardmäßig ist ein Ubuntu 16.04 LTS im UI Unterbau installiert.


    !!! EIN UPDATE auf aktuelles Ubuntu wird im Internet NICHT empfohlen. !!!

    Kennst du den Grund dafür? Funktioniert dann die Ubiquiti-Software darauf nicht mehr? Oder kann ein modernes Ubuntu mit dem Board nicht ...

  • Das währe ja schon ein NoGo für das Mainboard.

    Ganz genau! Würde mich aber wundern, eigentlich wird Serverhardware ja ganz gut unterstützt.


    Daher vermute ich, dass "nur" die Ubiquiti-Software danach nicht mehr läuft.

    • Hilfreich

    Bei den Updates SEHR VIEL GEDULD mitbringen und einfach machen lassen

    AUF KEINEN FALL - Selbst wenn das Gerät nicht mehr reagieren sollte - REBOOTEN.
    Irgendwann wird das schon fertig und das Gerät meldet sich wieder.

    Und das aus deinem Mund :grinning_face_with_smiling_eyes: :grinning_squinting_face:

    Gruß

    defcon

  • Anbei das Handbuch vom UAS-XG Motherboard

    Dateien

  • Ganz genau! Würde mich aber wundern, eigentlich wird Serverhardware ja ganz gut unterstützt.


    Daher vermute ich, dass "nur" die Ubiquiti-Software danach nicht mehr läuft.

    genau....da es seit 2018 kein Update der ISO mehr gibt...
    sind die beim 16.04 LTS da hängen geblieben.
    Lt. Internet funzelt dann Network nicht mehr, weil sich wohl im Ubuntu Kernel zu viel im Unterbau getan hat

    und das nicht mehr matched.


    Das Board hat damit REIN GAR NIX ZU TUN.

    letztes BIOS und BMC von 2021 !!! Also nix veraltetes

  • genau....da es seit 2018 kein Update der ISO mehr gibt...
    sind die beim 16.04 LTS da hängen geblieben.
    Lt. Internet funzelt dann Network nicht mehr, weil sich wohl im Ubuntu Kernel zu viel im Unterbau getan hat

    und das nicht mehr matched.


    Das Board hat damit REIN GAR NIX ZU TUN.

    letztes BIOS und BMC von 2021 !!! Also nix veraltetes

    Hätte mich auch gewundert, wenn dies ein Mainboard Problem wäre - wobei ich gerade das gegenteilige Problem erlebt hat

    Mainboard und CPU waren zu neu für den Linux-Kernel ( bei Proxmox ) - Fehler ist wurde aber schnell korrigiert im neusten Kernel.

  • Hätte mich auch gewundert, wenn dies ein Mainboard Problem wäre - wobei ich gerade das gegenteilige Problem erlebt hat

    Mainboard und CPU waren zu neu für den Linux-Kernel ( bei Proxmox ) - Fehler ist wurde aber schnell korrigiert im neusten Kernel.


    Kenn ich mit OPNSense auf einer unserer "Thomas Krenn" Low Energy Kisten...
    Nach den OPNSense update war die Kiste quasi "Fritte"
    Mussten den Komplett-Tausch mit BackupRestore durchführen.
    Im Nachgang war das lt. TK ein BIOS Problem.....Nach BIOS Update wollte dann auch das neuer Linux im Unterbau
    OHNE "verrecken" laufen....hahaha