Safari blockiert nach 90 Sekunden lokalen Moodle Server

Es gibt 6 Antworten in diesem Thema, welches 320 mal aufgerufen wurde. Der letzte Beitrag () ist von AMD.

  • Hallo,

    in unserem schulischen WLAN (61 Access Points) lässt sich unser lokaler Moodle Server (Ubuntu Server) seit einiger Zeit mit Safari nicht mehr normal nutzen: nach ca. 90 Sekunden ist Moodle "eingefroren", der Ladebalken bewegt sich nicht. Trennt man kurz die WLAN-Verbindung, hat man wieder ca. 90 Sekunden Nutzungszeit. Das ist natürlich sehr ärgerlich.

    Auf dem MacBook kann man in Google Chrome parallel dazu problemlos mit Moodle arbeiten - im selben WLAN. Per LAN-Kabel im passenden VLAN-Port ist Safari ebenfalls problemlos nutzbar. Externe Aufrufe von Moodle sind ebenfalls problemlos möglich.

    Auf iOS/iPadOS Geräten lässt sich das Safari-Problem mit Moodle nicht durch Chrome umgehen, sie müssen nach 90 Sekunden kurz das WLAN trennen.

    Android und Windows Geräte haben keine Probleme mit der Moodle-Nutzung im WLAN.


    Ich habe erfolglos alle Optionen im UniFi Network Controller durchgespielt.

    Aktiviert sind im old User-Interface:

    • WPA Personal
    • 2,4 & 5 Ghz (both)
    • Broadcasting all APs
    • Block LAN to WLAN Multicast and Broadcast Data
    • GTK rekeying every 3600 seconds
    • Multicast enhancement
    • High Performance Devices 5 Ghz only
    • add 802.11d country roaming enhancements
    • allow BSS Transition with WNM
    • PMF disabled
    • WPA2 only
    • DTIM Mode use default


    In der pfSense Firewall sind lokal keine Einschränkungen vorhanden, die pfSense ist DHCP Server.

    Der UniFi Controller läuft auf einem Mac im selben VLAN, dessen Firewall ist deaktiviert.


    Natürlich sind alle Firmware Updates installiert.


    In Safari habe ich alle Cookies gelöscht und alle Tracking-Optionen deaktiviert, also alles geöffnet (nur zum Test!).

    Da Safari und iOS über eine externe Verbindung per LAN kein Problem haben, muss es irgendetwas innerhalb des WLANs sein, was nach ca. 90 Sekunden "das Fass zum Überlaufen bringt". Natürlich habe ich nach irgendwelchen versteckten Caches o.ä. gesucht.


    Da ich Safari und/oder die UniFi Geräte nicht neu programmieren will/kann, kann ich nur mit den Einstellungen dieser beiden hantieren.


    Hat da jemand noch irgendeinen Tipp? 1.100 Nutzer wären dankbar!


    Vielen Dank fürs Lesen!

  • Evtl. Könnte es helfen, wenn du Mal die WLAN Einstellungen aus unifi Seite postest. Vielleicht fällt da einen was auf.


    Meines Wissens nach erlaubt Apple auf mobilen Geräten nur Browser auf Webkit-Basis. Somit ist da Chrome und Co. quasi ein angepasster Safari.


    Alternativ:

    Wie wäre es, wenn die 1.100 Nutzer sich separat an Apple wenden und fragen, was das sein könnte?


    Ich selbst habe allein darum privat kein Apple, weil ich gern MP3s unbegrenzter Länge und variabler Quelle als Klingelton nutze. Dass ich mein Dienst iPhone erst entsperren muss, um es am Sat-Receiver laden zu können, ist eine andere Geschichte.

  • Danke für deine Antwort!

    Die Einstellungen für das WLAN hatte ich schon aufgelistet, hier sind sie noch mal als Screenshot:


    Die Apple-Geräte funktionieren einwandfrei im Wlan (Internet, Mail ...) und auch bei der Nutzung von Moodle über das LAN bzw. im externen Zugriff über das Internet. Safari hat also kein Problem mit Moodle oder dem Ubuntu-Server, nur innerhalb des WLANs tritt das Problem auf. Das Problem wäre also sinnvollerweise im WLAN zu suchen (Konfiguration, Firmware, Hardware). Nur wo?

  • Meine unsortierten Gedanken dazu:


    Ich würde es mit mehr Standard Einstellungen probieren.


    Block LAN to WLAN Multicast und dann enable Multicast V3. Klingt widersprüchlich.


    Lass den Block weg. High Performer zu 5 GHz auch aus.


    Die neue Oberfläche soll wohl nur noch genutzt werden.


    Evtl. Verweist der Moodle Server auf externe Inhalte, die vom IPS blockiert werden.

  • Block LAN to WLAN Multicast war nötig, da unsere 61 Apple TVs, 61 Chrome Casts und die 61 Miracast Geräte (TVs) das Netz überflutet hatten. Stimmt: enable Multicast macht in der Kombination vermutlich wenig Sinn. Ich meine ich hätte das schon mal deaktiviert und als erfolglos getestet, vielleicht habe ich aber auch zu früh getestet und nicht auf die Auslieferung der geänderten Konfiguration an die APs gewartet. Das teste ich noch mal. Danke für den Hinweis!


    High Performance 5 Ghz hatte keine Auswirkungen auf das Problem. Da es beta ist, deaktiviere ich es mal wieder.


    Mit der neuen Oberfläche kann ich mich noch nicht anfreunden, da fehlt mir immer etwas. Da es - hoffentlich - nur eine Frage der optischen Darstellung ist und nicht in die Funktionalität eingreift, nutze ich lieber noch die alte Oberfläche. Aber auch das teste ich noch mal. Wer weiß ...


    Danke erstmal, ich melde mich in den nächsten Tagen hier noch mal.

  • Deine Hoffnung muss ich leider trüben. Es hat sich schon diverse Male gezeigt dass Einstellungen die in der alten GUI gemacht werden nicht mehr richtig ziehen. Auch wenns ungewohnt ist und man manche Sachen vermisst sollte tatsächlich nach Möglichkeit nur noch die neue GUI benutzt werden.

  • Ich habe weitere erfolglose Tests durchgeführt:

    • Unter der neuen Oberfläche habe ich ein neues WLAN erstellt und ohne weitere Konfiguration auf Save gedrückt. ( KJL: Danke für den Hinweis)
    • Mit den Multicast-Optionen habe ich in allen möglichen Kombinationen herumgespielt.

    Da ich so nicht weiterkomme, habe ich noch mal grundsätzlich an zeitlich befristete Dienste im Netz gedacht und bin auf die DHCP Lease Time gestoßen. Da hier ja grundsätzlich keine Probleme bestehen, da Internetnutzung funktioniert, habe ich nach möglichen Konflikten mit UniFi Network gesucht. Dort ist aber DHCP deaktiviert, also auch kein Einfluss zu erwarten.

    Zufällig habe ich unter Routing & Firewall > Firewall > Settings > State Timeouts gefunden. Die Unifi Firewall soll eigentlich nur zusammen mit einem USG funktionieren, aber wer weiß. Ich habe alles deaktiviert und alle Werte auf 7200 gesetzt. Das ist die default lease time bei pfSense, ein anderer Wert fiel mir gerade nicht ein, es sollte ja auch eigentlich keinen Einfluss haben, da die Firewall ja gar nicht aktiv sein sollte.


    Testen kann ich erst in ein paar Tagen wieder.