Fritz!Box 7490 für DECT Telefonie hinter Unifi Express - Telefone nach kurzer Zeit nicht mehr von aussen erreichbar

Es gibt 19 Antworten in diesem Thema, welches 1.190 mal aufgerufen wurde. Der letzte Beitrag () ist von D4RK1.

  • Hallo,


    bin gerade erst von der Fritte auf Unifi gewechselt, läuft auch soweit alles, bin noch nicht sonderlich weit mit der Netzwerkkonfiguration (will noch VLANs einrichten usw.), aber vom Prinzip her läuft alles mit der UX, nem 16er Lite Switch und zwei AC Lite APs. Des weiteren habe ich die Fritte jetzt halt für die DECT Telefonie degradiert.


    Mit der Standalone Fritte hat das mit der Telefonie alles einwandfrei funktioniert, habe sie jetzt nach dem Video von iDomiX konfiguriert und das WLAN abgeschaltet. Ansonsten habe ich an den Konfigurationen nichts geändert. Aber irgendwie kann man die IP Telefone jetzt nach kurzer Zeit von aussen nicht mehr erreichen. Wenn ich die Fritzbox neu starte, dann geht es eine Weile, aber irgendwann nicht mehr.


    Habe mir die Einstellungen in der Fritte noch weiter angeschaut und die Funktion "Portweiterleitung des Internet-Routers für Telefonie aktiv halten. Diese Option kann dann erforderlich werden, wenn der Internet-Router ankommende Telefonate nicht mehr an FRITZ!Box weiterleitet. FRITZ!Box hält die Portweiterleitungen des Internet-Routers für Telefonie aktiv" aktiviert. Als Wert habe ich alle 5 Minuten eingestellt.


    Hat jemand noch eine Idee, muss ich vielleicht an der UX noch was einstellen? Hoffe jemand hat nen Tipp =)


    Gruß, Jens

  • Vieeeeeeeel kürzer, jedenfalls wen auf dem Unifi Router nichts geändert wurde.


    Das Nat Time Out für UDP ist bei Unifi bei 30 Sekunden. Da kommt es immer wieder zu Überscheidungen die nicht passen.

    Daher diesen Timeout auf 300 Setzen und dann hast du Ruhe mit den Üblichen SIP Providern (und AVM natürlich auch

    „port Offen halten“




    Und da wissen AH macht...


    Das Nat System merkt sich Verbindungen von A nach B und hält den Rückkanal

    dazu offen und leitet die Pakete wieder dahin wo sie hingehören. Das ist Quasi

    wie ne Dynamische Portweiterleitung zu verstehen und DIE Kern Funktion

    von Port Basierten PAT / PNAT.


    Sollte ne Zeit Lang nichts

    darüber laufen und die Verbindung nicht geschlossen worden sein wird sie halt nach dem TimeOut

    gelöscht. Das Passiert bei SIP und den 30 Sekunden schneller als man schauen kann.

    Der Anrufer von Extern Klingelt dann zwar bei deiner IP, der router weis dann aber nicht mehr

    damit anzufangen.

  • Hallo,


    danke für eure Antworten, ich habe das jetzt erstmal nur in der Fritte auf 30s gestellt. Werde es später testen, wenn ich jetzt anrufe macht mich meine Frau nen Kopf kürzer..


    Gruß und Dank,

    Jens

  • hm... also erst ging es (also paar Stunden nach der Anpassung auf 30s probiert) mit dem Anrufen von Aussen (mit Handy auf "Festnetz" angerufen). Dann ging es irgendwann nicht mehr. Zudem konnte ich dann auch nicht mehr nach "Draußen" anrufen. Dann noch mal probiert mit Fritte neustarten und als das nicht half auch mal die UX neugestartet. Auch nicht funktioniert. Aktuell habe ich auch in der Fritte die Anzeige "Telefonie: 1 Rufnummer aktiv, davon keine registriert". Fritte nochmal neu gestartet, aber keine Änderung.


    Jemand noch ne Idee woran das liegen könnte?

  • Das Nat Time Out für UDP ist bei Unifi bei 30 Sekunden. Da kommt es immer wieder zu Überscheidungen die nicht passen.

    Daher diesen Timeout auf 300 Setzen und dann hast du Ruhe mit den Üblichen SIP Providern (und AVM natürlich auch

    „port Offen halten“

    Aus Neugier, welche Option ist das aus dem Screenshot?

  • Aus Neugier, welche Option ist das aus dem Screenshot?

    Ich finde das nur im legacy gui hier:


    Der Screenshot oben sieht anders aus. also müßte das auch in der neuen GUI zu finden sein - nur ich finde es nicht.

    *******************************************************************************************************************************************************************************

    UniFi Switch PRO 24 PoE, UDM Pro, UAP Pro, UAP nanoHD, UAP-FlexHD, U6-Mesh, U6 Pro

    Mini Switch, Switch 8 POE 150, Kabelmodem TC4400; FB 6591, Synology NAS, Pi Hole, U-LTE-Pro

    UNVR, UVC-G3-FLEX, UVC-G4-BULLET

  • Ah gefunden: https://xxx.xxx.xxx.xxx/networ…s/security/firewall-rules

    und dann advanced aktivieren und schon sieht man conntrack options und timeout settings

    *******************************************************************************************************************************************************************************

    UniFi Switch PRO 24 PoE, UDM Pro, UAP Pro, UAP nanoHD, UAP-FlexHD, U6-Mesh, U6 Pro

    Mini Switch, Switch 8 POE 150, Kabelmodem TC4400; FB 6591, Synology NAS, Pi Hole, U-LTE-Pro

    UNVR, UVC-G3-FLEX, UVC-G4-BULLET

  • Hi...kurzes Update... ich habe nichts weiter gemacht.... eben klingelt das Telefon und ich denke mir "hääääh", dann schau ich in die Fritte, plötzlich steht da wieder "1 Rufnummer aktiv". Kein Plan..


    Diese "aktiv halten" "Pings" gehen aber nur an die UX, oder kann es sein, das der ISP da irgendwie was von mitkriegt und wegen "Spam" temporär dicht gemacht hat?


    Leider ist der Anruf dann nach kurzer Zeit abgebrochen.... In der Fritte allerdings immer noch "aktiv"

  • und dann advanced aktivieren und schon sieht man conntrack options und timeout settings

    Danke, Die UI habe ich schon gefunden, wollte nur wissen welchen UDP Eintrag gierig da genau meint den man auf 300 stellen soll.

  • Diese "aktiv halten" "Pings" gehen aber nur an die UX, oder kann es sein, das der ISP da irgendwie was von mitkriegt und wegen "Spam" temporär dicht gemacht hat?

    Das "aktiv halten" ist immer gegenüber dem vorgeschalteten Router, mit dem Provider hat es an dieser Stelle nichts zu tun.


    Diese Einstellung brauchst Du auch nur in genau dieser einen Konfiguration, also Fritzbox als Telefonanlage kaskadiert hinter einem anderen Router.


    Zum Verständnis: Ein NAT-Router leitet von innen nach außen grundsätzlich alle Anfragen weiter und merkt sich den jeweils Anfragenden (das konkrete Gerät). Kommt dann die Antwort vom jeweiligen Server aus dem Internet, wird diese an das zuvor gemerkte Gerät weitergeleitet. Ansonsten wäre bei mehr als einem Computer im Netzwerk unklar, wohin jetzt der Youtube-Stream, wohin die E-Mail und wohin die Website-Daten fließen müssen.

    Anfragen von außen nach innen hingegen werden grundsätzlich verworfen, wenn keine expliziten Regelungen greifen (eine Portweiterleitung z.B.). Das sind aus Sicht des Routers "unangeforderte Datenpakete" - und das Wesen von eingehenden Anrufen ist es eben, dass man sie nicht von innen nach außen aufbaut.

    Die Fritzbox wiederum teilt dem Router mit, dass eingehende Anrufe bitte an sie weiterzuleiten sind. Daraus entsteht technisch betrachtet eine offene Verbindung, über die aber keine Daten fließen, solange nicht telefoniert wird. Solche ungenutzten, offenen Verbindungen schließt jeder Router nach einer gewissen Zeit, das hat vor allem Performance-Gründe und gilt für alle Arten von Protokollen, also nicht nur für VoIP-Telefonie.

    Durch "aktiv halten" erneuert die Fritzbox die offene Verbindung einfach so regelmäßig, dass es zu keinem Timeout mehr kommt. Somit klappt es dann mit den eingehenden Anrufen zuverlässig.

  • Das "aktiv halten" ist immer gegenüber dem vorgeschalteten Router, mit dem Provider hat es an dieser Stelle nichts zu tun.


    Diese Einstellung brauchst Du auch nur in genau dieser einen Konfiguration, also Fritzbox als Telefonanlage kaskadiert hinter einem anderen Router.



    Danke für deine Antwort, hast du ne Idee woran das mit den abbrechenden Anrufen liegen könnte? Sollte ich das mit den UDP Einstellungen in der UX mal testen?


    Gruß. Jens

  • Mit den Werten rumzuspielen kann nicht schaden (solange Du Dir die Änderungen für Dich selbst dokumentierst.

    VoIP wird leider gefühlt von jedem Provider etwas anders implementiert, sodass es es keine für überall pssende Wege und Werte gibt, am besten sprichst Du Deinen Provider einmal darauf an.


    Brechen Anrufe denn grundsätzlich ab oder nur teilweise? Und nach welcher Dauer?

  • Nach meiner Erfahrung ist es hier aber nicht unbedingt notwendig, für VoIP einen Wert anzupassen.

    Da hast du mich falsch verstanden :winking_face: , ich bin ja schon in der Ansicht, es gibt nur mehrer UDP Einstellungen dort, da weiß ich nicht genau welche gierig genau meinte. Ich hatte eh vor, VOIP hinter der UDM pro bei mir nochmal ne Chance zu geben und habe die Hoffnung dass es damit eventuell gehen könnte.

  • So da bin ich wieder...


    wollte nur wissen welchen UDP Eintrag

    Eigentlich nur UDP, es schadet aber nicht auch UDP-Stream zu erhöhen.

    Der ist in der Conntrack Tabelle eigentlich für „Kontinuierliche Stream in beide Richtungen“.


    Diese "aktiv halten" "Pings" gehen aber nur an die UX, oder kann es sein, das der ISP da irgendwie was von mitkriegt und wegen "Spam" temporär dicht gemacht hat?

    Durch "aktiv halten" erneuert die Fritzbox die offene Verbindung einfach so regelmäßig, dass es zu keinem Timeout mehr kommt. Somit klappt es dann mit den eingehenden Anrufen zuverlässig.

    Das "Aktive halte"n des Rückkanals in der Conntrack Tabelle de NAT Systems

    findet dadurch statt das zu dem Ziel Irgendwas gesendet wird.

    Irgendwas muss also zum Server des Providers. ob das nu ein „Fake“ Paket ist oder

    ein echter SIP Option Request ist technisch egal zum Offenhalten des NAT Tunnels.


    Der Provider könnte (muss aber nicht) aber dennoch sagen „Nö du bist doof dich sperre ich“

    Telekom Privatkunden Anschlüssen waren vor ein paar Jahren SEHR empfindlich.

    Du wurdest 20 min geblockt wenn du einen Option Request gesendet hast oder

    dich öfters als alle 4 min Registriert hast (und und wird’s abgemeldet wenn der

    Reregister nicht nach 5 min gekommen ist..


    Nach meiner Erfahrung ist es hier aber nicht unbedingt notwendig, für VoIP einen Wert anzupassen.

    Nach meiner schon, nicht jeder hat ne FritzBox


    Ganz Allgemein:

    Wenn es so garnicht klappen sollte. Testet eine Feste Portweiterleitung vom SIP

    Port auf deine Fritzbox. Mitunter kommen Invites von anderen voice Gateway des Provider

    Weil er einfach davon ausgeht das die TK Anlage direkt auf dem router hängt und

    auf alle Quellen direkt lauschen kann. Würde aber nicht unbedingt für die Voice Kompetenz

    deines Provides Sprechen....

  • Danke gierig für die mal wieder sehr kompetenten und bewusstseinserweiternden Erklärungen! :smiling_face_with_sunglasses:

    Da war mir einiges so im Detail noch nicht klar.

    Nach meiner schon, nicht jeder hat ne FritzBox

    Stimmt natürlich, ich hatte mich mit der Aussage aber (nicht ganz eindeutig) auf diesen konkreten Fall bezogen, in dem ja eine Fritzbox im Spiel ist.

    Neben Fritzboxen habe ich aber auch Snom, Gigaset und Yealink Geräte an UDMs vorbei verbunden, ohne dass an dieser Stelle Änderungen der Standardwerte nötig waren. Es hängt aber ohne Zweifel auch immer am Provider, da ist mein Erfahrungsschatz noch etwas begrenzt (Sipgate, Fonial, Easybell und 1&1).

  • Danke gierig und Networker mal wieder für die Infos, ich werde mal beobachten, ob diese Abbrüche weiter vorkommen und ob ich irgendwelche Regelmässigkeiten feststellen kann.


    Blöderweise bin ich hier nicht der "Telefonierer" und erfahre von den Problemen meist erst aus zweiter Hand.... Wenn ich über das "Festnetz" telefoniere, dann rufe meistens ich woanders an, mal sehen obs da auch passiert. Zudem telefoniere ich meistens nicht sonderlich lange ^^. Von daher wird das wohl schwierig zu eruieren sein. Vielleicht kann ich meine Frau dazu bringen zu notieren wann es passiert und kann dann in der Fritte nachschauen.


    Gruß, Jens